Electronique : première tentative de montage

Règles du forum
Cette section est dédié a vos projets, descriptions et demandes d'aide.
Merci de limiter le nombre de sujet par projets.
Lorsqu'un sujet deviens long vous pouvez éditer le premier message pour maintenir à jour le descriptif et garder en lisibilité
treblig
Electrolab::Membre
Messages : 52
Enregistré le : 17 sept. 2018, 11:39

Electronique : première tentative de montage

Messagepar treblig » 08 nov. 2018, 18:29

Message supprimé. Ma demande n'étant, semble-t-il, pas assez explicite.

Treblig
Modifié en dernier par treblig le 09 nov. 2018, 12:04, modifié 1 fois.
Avatar de l’utilisateur
NicoM
Electrolab::Membre
Messages : 65
Enregistré le : 01 mars 2017, 16:05
Localisation : Chez oim
Contact :

Re: Electronique : première tentative de montage

Messagepar NicoM » 08 nov. 2018, 22:12

Bonsoir
Vu que tu as des pattes libres sur ton ATTtiny, tu peux simplifier grandement : tu mets ton inter sur deux entrées, des MOS de commande de LEDs sur deux sorties et ton buzzer sur une troisième. Ça élimine le problème de la génération de qq kHz pilotée par un signal 1,5 Hz

Nico M
treblig
Electrolab::Membre
Messages : 52
Enregistré le : 17 sept. 2018, 11:39

Re: Electronique : première tentative de montage

Messagepar treblig » 08 nov. 2018, 22:26

NicoM a écrit :Bonsoir
Vu que tu as des pattes libres sur ton ATTtiny, tu peux simplifier grandement : tu mets ton inter sur deux entrées, des MOS de commande de LEDs sur deux sorties et ton buzzer sur une troisième. Ça élimine le problème de la génération de qq kHz pilotée par un signal 1,5 Hz

Nico M


Bonsoir,

Oui mais je réservais les GPIO autant que possible pour les V1, V2, ...
D'un autre côté, c'est vrai que je ne pourrais pas mettre une masse de code dans le ATtiny et qu'il faudra peut-être passer à l'ATmega328 (le 2560 serait probablement trop gros pour rentrer dans le cintre du vélo) pour ces autres versions.

Il ne faut pas hésiter à critiquer mon schéma, même tel qu'il est, pour moi le but c'est de comprendre.

Treblig
Avatar de l’utilisateur
NicoM
Electrolab::Membre
Messages : 65
Enregistré le : 01 mars 2017, 16:05
Localisation : Chez oim
Contact :

Re: Electronique : première tentative de montage

Messagepar NicoM » 09 nov. 2018, 09:54

J'avais sauté directement au schéma mais j'aurais dû m'attaquer à ton cahier des charges d'abord.
Pour ce qui est de la consommation, tu auras toujours intérêt à alimenter ton circuit avec la tension la plus basse possible, même avec un régulateur de tension linéaire. En revanche, il est plus intéressant d'alimenter les LED directement depuis la batterie, surtout si tu veux en allumer beaucoup en même temps.
Je ne vois pas l'intérêt de mettre un isolateur entre le µC et le MOS, tu n'as aucune de tension dangereuse nulle part, tu pilotes juste des LED. Une résistance série suffit largement à protéger la sortie du µC.
Tu n'as pas à t'inquiéter pour ton comodo, tu n'auras jamais 50V ni 500mA dans ton circuit (une LED c'est 50mA grand grand max). Et je ne vois pas quel risque tu imagines à les mettre sur le drain du MOS, c'est même comme ça qu'il faut faire (car si tu les mets sur la source il te faudra une tension de grille plus élevée -Vgs>0- que ton µC ne pourra pas fournir. L'autre avantage de ce montage dit "en drain ouvert" c'est que tu peux alimenter les LED avec n'importe quelle tension)
En ce qui concerne la raideur des fronts de ton signal de commande, on parle de l’œil humain, là. Tout allumage ou extinction plus rapide que 10ms sera imperceptible et semblera instantané. En électronique, 10ms c'est une éternité.
MOS-P contre MOS-N : ils sont symétriques, le N est passant si Vgs > Vgson (avec Vgson > 0), pour le P c'est Vgs < Vgson avec Vgson < 0. Tu as ici avantage à utiliser un MOS-N en drain ouvert pour pouvoir alimenter les LED depuis la batterie. Accessoirement, la physique des semiconducteurs fait que les MOS-P sont globalement moins bons que les MOS-N.
Pour ton buzzer, est-ce que tu veux qu'il sonne en continu tant que ton clignotant clignote, ou seulement quand il est allumé ? Plutôt qu'une multiplication de fréquence, qui est chose relativement compliquée, je verrais plutôt un oscillateur fait avec une porte logique commandé par ton signal à 1,5Hz

Nico M
Avatar de l’utilisateur
Flax
Electrolab::CA
Messages : 368
Enregistré le : 01 mars 2017, 20:46
Contact :

Re: Electronique : première tentative de montage

Messagepar Flax » 09 nov. 2018, 10:34

Bonjour,

Alors, je vais peut-être passer pour un maniaque, mais très honnêtement, je ne comprend pas du tout ce que tu veux faire avec ce circuit, donc je ne vois pas comment je pourrais le critiquer. :-/

treblig a écrit :Les plus aguerris peuvent voir le montage que j'essaie de réaliser dans le lien donné ci-dessus et les contraintes.

Euh ... 8/ Moi je ne comprends pas du tout. A mon avis c'est une mauvaise approche : faire une proposition dans un domaine qu'on ne maîtrise pas en pré-supposant que les gens en face, plus compétents, trouveront les solutions d'eux-même, ça ne marche que si le problème est clairement défini ... Ce qui, à mon humble avis, n'est pas le cas ici.

En particulier, "passer d'un signal de 1-2Hz à 4kHz" je ne comprends pas du tout ce que ça veut dire. Qu'est-ce que ce circuit doit faire, concrètement ? Pourquoi 4kHz ? Ça sert à quoi ? C'est de la modulation de fréquence ? Modulation d'amplitude ?
Et, surtout, tu dis que le microcontrôleur que tu as choisi est peut-être trop petit et que tu penses qu'il faut un plus gros. Trop petit par rapport à quoi ? Tu veux mettre quoi dedans ? Quelle est la fonction qu'il doit réaliser ? Parce que là, je vois juste un MCU avec une pin reliée sur la grille d'un MOSFET. C'est quoi la commande ? Du statique ? Du PWM ?
Je tique là-dessus parce que c'est un problème que j'ai tout le temps au taf, les clients veulent faire un truc, mais ils savent pas exactement quoi, mais il faut qu'on choisisse un MCU, donc, forcément, on choisis toujours le mauvais :diable: Sérieusement, choisir un microcontrôleur ça ne se fait pas au doigt mouillé, surtout quand tu es obligé de prendre le plus petit possible pour des contraintes de conso / prix / encombrement.

Bon, désolé de faire mon relou, mais ce n'est pas la première fois que je fais ce genre de remarque, loin de là, et c'est une erreur classique quand on débute dans un domaine technique, qui est de se jeter dans les détails d'implémentation en délaissant la définition de ce qu'on veut faire. C'est le meilleur moyen de se prendre les pieds dans le tapis en faisant du solutionnisme. No offense, s'pas ? Juste, j'insiste : il faut décrire EXPLICITEMENT ce qu'on veut faire, sinon c'est de la devinette. Et dans mon milieu, faire des specs avec des trous et des exigences pas explicites c'est une technique classique utilisée pour enfler les sous-traitants. Donc forcément, j'ai un léger à-priori négatif :diable: Et puis, intrinsèquement, ça ne marche juste pas. Et très souvent, le fait de se forcer à exprimer clairement ce qu'on veut faire permet de trouver tout seul quelle est la solution à mettre en œuvre.

treblig a écrit :Comme pour tout mon montage, les contraintes sont : la consommation et l'emprise sur le PCB.

[TROLL] Non. Il existe plein de montages pour lesquels la contrainte PRINCIPALE c'est que ça coûte pas cher à fabriquer en grande série, mais OSEF de la conso et de la place que ça prend. Et d'autres montages sur lesquels la contrainte PRINCIPALE c'est la robustesse et la précision.[/TROLL] Désolé, je taquine, c'est juste que je ne supporte pas les énoncé qui commencent par "de tous temps les hommes ont fait ceci ou cela", ça me hérisse le poil :erk: J'ai déjà précisé que j'étais maniaque ? :aille2:
treblig
Electrolab::Membre
Messages : 52
Enregistré le : 17 sept. 2018, 11:39

Re: Electronique : première tentative de montage

Messagepar treblig » 09 nov. 2018, 12:05

Bonjour,

@NicoM : merci de ton retour, c'est très instructif. A priori le buzzer fonctionne au rythme des clignotants (env. 1,5 Hz).

@Flax : message reçu. Je pensais avoir fourni pas mal d'explications sur le but que je poursuivais ainsi que le schéma (sans doute contestable) dans le lien que je donnais. A l'évidence, j'avais tord. Mea culpa, mea maxima culpa. Je supprime donc mon post initial de sorte que personne ne perde son temps sur ma bidouille.

Incidemment, je n'ai pas écrit "Comme pour tout montage, les contraintes sont : la consommation et l'emprise sur le PCB" mais "Comme pour tout mon montage, les contraintes sont : la consommation et l'emprise sur le PCB" donc je ne comprends pas le paragraphe "[TROLL]" qui généralise mes contraintes à n'importe quel autre montage. No offense, s'pas ?

Treblig
Avatar de l’utilisateur
Flax
Electrolab::CA
Messages : 368
Enregistré le : 01 mars 2017, 20:46
Contact :

Re: Electronique : première tentative de montage

Messagepar Flax » 09 nov. 2018, 13:07

treblig a écrit :Je supprime donc mon post initial

AAAh mais non, c'est pas ça que j'ai dit ! Au contraire, garde-le, mais complète les specs, décris explicitement ce que tu cherches à faire !
Le problème n'est pas que le post doit être supprimé, le problème c'est qu'il est incomplet. Une fois complété il sera beaucoup plus facile pour quelqu'un de l'extérieur de comprendre et donc d'aider.
Je sais que c'est compliqué, mais il faut se mettre à la place de la personne à qui on pose une question, ne pas partir du principe qu'elle peut deviner ce qui n'est pas dit. Ça ne veut pas dire qu'il ne faut pas poser la question, ça veut dire qu'il faut poser la question en entier.
Pas d'implicite, l'implicite c'est le mal.

treblig a écrit :Comme pour tout mon montage

Donc le smiley diable était de circonstance, il est bien dans les détails ... même grammaticaux :mrgreen:
treblig
Electrolab::Membre
Messages : 52
Enregistré le : 17 sept. 2018, 11:39

Re: Electronique : première tentative de montage

Messagepar treblig » 09 nov. 2018, 20:13

NicoM a écrit :Tu n'as pas à t'inquiéter pour ton commodo, tu n'auras jamais 50V ni 500mA dans ton circuit (une LED c'est 50mA grand grand max).
Le switch ON-OFF-ON (qui a rendu l'âme mécaniquement) du comodo est donné pour ces valeurs mais je ne garantis pas qu'il les tienne : c'est du très, très cheap mais la plasturgie et les dimensions de ce commodo sont idéales pour mon besoin. Je n'ai trouvé de switchs de remplacement aux bonnes dimensions que sur aliexpress (à 0,08€ le bout livré, ça risque de ne valoir que 0,08€...) mais je ne suis pas à l'abri de ne pas savoir chercher.

Sur le schéma de principe j'ai indiqué une seule LED : 1. pour ne pas encombrer le schéma et 2. parce que le soft que j'utilise pour le faire n'est pas représentatif de l'état de l'art ;) et toute modif entraîne une catastrophe dans d'autres parties du circuit. Pour faire bref, j'indiquais dans mon blabla/cahier des charges que "5 ou 6 LED orange (2,2V - 20mA) dans chaque clignotant devraient suffire" (j'ai des LED oranges avec ces caractéristiques en stock d'où ce choix mûrement réfléchi) et je donnais aussi les dessins des "strings" de LEDs, un pour une alim en 3V et un pour une pour alim en 5V en bas de mon schéma. Je les ai extraits, ils sont visibles ici.

NicoM a écrit :je verrais plutôt un oscillateur fait avec une porte logique commandée par ton signal à 1,5Hz
OK, intéressant. Quelque chose comme un de ceux là (honteusement pompés sur le net) ?
J'avoue que là je sèche pour calculer la valeur des composants passifs autour des NAND. Certes je pourrais mettre des valeurs sorties de mon chapeau pour les capas et des résistances variables jusqu'à ce que ça fasse +/- ce que je veux mais ça ne ferait pas avancer mes connaissances ;)

Flax a écrit :AAAh mais non, c'est pas ça que j'ai dit ! Au contraire, gardes-le, mais complètes les specs, décris explicitement ce que tu cherches à faire !
Le problème n'est pas que le post doit être supprimé, le problème c'est qu'il est incomplet. Une fois complété il sera beaucoup plus facile pour quelqu'un de l'extérieur de comprendre et donc d'aider.
Incomplet à quel niveau ? Le post comportait le lien vers un très long blabla et schéma qui expliquaient le but, les contraintes, les doutes sur telle ou telle partie du montage et un certain nombre de questions. Compléter les specs jusqu'à quel niveau de détail ? Là, c'est pour faire clignoter des LED et sonner un buzzer et c'était décrit dans le blabla qui comprenait aussi des liens vers les specs des composants que je comptais utiliser au cas où leurs caractéristiques particulières pourraient influer sur les réponses à mes questions.

Ce blabla a-t-il été lu et, si oui, ne comportait-il vraiment aucune indication sur les tenants et aboutissants du circuit, y compris pour cette "blackbox 1,5Hz -> 4KHz" ? N'y avait-il pas la source du signal et le dessin de la forme du signal 1,5Hz ? N'y avait-il pas le schéma et la description du piezzo destiné à recevoir le signal 4 KHz ? N'y avait-il pas un lien vers les specs constructeur du piezo ?
Jusqu'où et sous quelle forme compléter les specs (ce n'est pas une question rhétorique) ?

Certes, mon blabla (beaucoup trop long pour le poster en entier sur le forum) n'était pas un cahier des charges formel approuvé par une MOA spécialisée mais, quand même, il a permis à un autre membre du Lab de m'apporter des pistes intéressantes et des réponses explicites à certaines de mes questions, je suis donc vraiment surpris de m'être pris une telle et longue volée de bois vert.
Bienvenue à l'Electrolab...

Treblig
Avatar de l’utilisateur
nats
Electrolab::Membre
Messages : 61
Enregistré le : 25 févr. 2018, 10:13

Re: Electronique : première tentative de montage

Messagepar nats » 09 nov. 2018, 20:38

Treblig je me permets de te répondre.
Ta réaction est vraiment inutilement agressive, sache que Flax est un des plus enclins à aider en électronique au lab et il est de très bon conseil.

Je ne comprends pas pourquoi tu te vexe et au passage:
je suis donc vraiment surpris de m'être pris une telle et longue volée de bois vert.


A aucun moment Flax ne t'a engueulé il t'a donné des conseils pour que plus de monde puisse t'aider quand tu cherche une réponse. Bref je te conseille vraiment de "chill out" et d'éviter de généraliser.

Bref pour le coté constructif je pense que tu devrais reposter le premier message avec les liens comme ça on pourra mieux te dire ce qui ne va pas.

Bonne soirée en espérant que ce ne soit qu'un malentendu et une prise de tête passagère suite à une incompréhension textuelle :)
Avatar de l’utilisateur
Steve
Electrolab::CA
Messages : 756
Enregistré le : 26 sept. 2016, 00:08
Référent : Zone Meca

Re: Electronique : première tentative de montage

Messagepar Steve » 09 nov. 2018, 22:37

Oui, messieurs, je ne vois aucune aggressivité là-dedans, ni aucune mauvaise volonté, connaissant les deux parties !
Juste de l'incompréhension, liée à un media écrit... Je ne pense pas que Gilbert se soit réellement pris une volée de bois vert, ni que c'eut été l'intention de Flax, juste que bon, décrire des schémas élec et des graphsets dans la langue de molière,
spafacile (tm). Il faut continuer sur une discussion technique, quitte à se prendre 1h devant le velleda pour faciliter la communication.
Désolé de ne pas avoir pu prendre assez de temps pour lire tous les posts/liens afférents en détail, mais je suis dispo pour une 'prise de tête' un de ces soirs.
(Au passage, peut-être à mettre dans un lightning-talk, dès qu'on aura un créneau ?)

Retourner vers « Les Projets »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité