Réparation BOSS SYB-5 Bass Synthesizer

Règles du forum
Cette section est destinée a recueillir toutes les discutions qui n'ont pas leur place ailleurs: sites web intéressants, histoires persos,...
Pour vos petites annonces et les fournisseurs de matériaux et d'outillages préférez les sous sections spécialisées
Avatar de l’utilisateur
Flax
Electrolab::CA
Messages : 1011
Enregistré le : 01 mars 2017, 20:46
Contact :

Réparation BOSS SYB-5 Bass Synthesizer

Messagepar Flax » 19 sept. 2020, 17:12

Ce n'est pas vraiment un projet je trouve donc je le met dans blabla.

Il s'agit d'un pédale d'effet pour basse, qui permet de générer des sons de synthétiseur mono à partir du signal d'une basse standard.

IMG_20200918_172953.jpg
IMG_20200918_172953.jpg (263.64 Kio) Vu 363 fois


https://www.boss.info/global/products/syb-5/

https://www.youtube.com/watch?v=QMbP3Yr2nmk

Effectivement, "fat" est un qualificatif adapté pour décrire le son qui sort de cette chose.

L'objet présente un comportement eratique, avec des sautes de niveau de sortie très brutales, de la saturation avec des effets de seuil très violents, voire certains effets qui ne marchent carrément pas. A l'ouverture rien de flagrant, pas de composants cramés visibles.

Je pars donc à la recherche du schéma. Pas la peine de regarder dans le manuel, il n'y a bien entendu aucun info sur le fonctionnement interne de l'appareil. Par contre, on trouve assez facilement le manuel de maintenance, qui n'est pas censé être public, mais bon, hein, on est en 2020, google, syb-5 service manual et on trouve assez facilement le doc.

IMG_20200918_172959.jpg
IMG_20200918_172959.jpg (501.56 Kio) Vu 363 fois


IMG_20200918_173009.jpg
IMG_20200918_173009.jpg (514.89 Kio) Vu 363 fois


Le schéma n'a rien de passionnant, il s'agit bien évidemment d'un circuit full-numérique, avec juste du front-end analogique en entrée et en sortie, un codec, et les effets sont fait en logiciel, via un couple MCU + DSP. De l'ultra-classique.

Le MCU est un uP780034 de chez Renesas (fondeur japonais, cela va de soi ...) malgré son marquage BOSS. C'est un petit MCU 8-bits en boîtier 64 pins. Il peut fonctionner avec un quartz de 8MHz à 38MHz, la fréquence max du CPU n'est pas donnée explicitement, mais vu qu'il n'y a pas de PLL intégrée mais uniquement des prescalers, cela signifie qu'il ne pourra jamais dépasser la fréquence max autorisée pour le quartz, 38MHz donc. Très clairement son rôle est juste de gérer l'interface utilisateur, donc la LED, le footswitch et les potars. Il y a aussi une petite liaison SPI qui va vers un connecteur, sans doute pour du test fin de chaîne / SAV ou tout simplement pour la prog du MCU. Il n'y a pas de port JTAG explicite, donc si ça se trouve c'est cette liaison qui sert à programmer le MCU, quoiqu'il pourrait être soudé programmé, mais je suspecte que le design soit générique, et différentié via une reprog, donc il est très probable que le MCU soit programmé sur la chaîne de prod. Autre possibilité : il est monté programmé avec un bootloader, et sur chaîne ils programment l'appli via la SPI, ce qui me semble le plus probable.

Le codec est un AKM AK4552 (fondeur japonais, bien entendu ...), la référence est obsolète et n'apparaît même plus sur leur site, on ne trouve que la doc du remplaçant, le AK4556. Les codecs AKM sont très courants dans les appareils de grande série, ce sont des composants difficiles à obtenir en tant que particulier, il n'y a que Digikey qui en propose en petites quantités. En vrai dans tous les appareils audio numérique que j'ai pu ouvrir ou dont j'ai pu voir le schéma, systématiquement les codecs sont des AKM.

Le DSP est siglé BOSS, et il est bien entendu impossible de trouver la moindre documentation. Impossible de savoir donc s'il s'agit d'un DSP ROMless, ou s'il est programmé au démarrage par le MCU via le port parallèle entre les deux. Il n'y a pas de puce de flash ou d'EEPROM sur le schéma, donc si le DSP est ROMless c'est le MCU qui doit le programmer et le booter au démarrage, ce qui me surprendrait vu le peu de mémoire flash dont le MCU dispose. C'est le plus gros modèle de la famille, mais bon, 32ko c'est pas énorme, mais si les algos sont simples ptet ça rentre ... Sinon, si le DSP a de la flash programme intégrée, il est probable qu'il soit programmé sur chaîne via le MCU, ou monté programmé, mais j'en doute.

C'est une architecture très courante dans les designs des appareils audionumériques japonais : un MCU Renesas, un ou plusieurs codecs AKM, et un DSP propriétaire. Genre, dans les tables de mixage numériques 01V et dérivés de Yamaha sont basés sur le même genre d'architecture. Sony aussi utilise souvent des DSP / ASICs custom. Après, il n'y a pas vraiment d'alternative efficace. Effectivement, si on met de côté le chauvinisme / protectionnisme des designers japonais (des préjugés ? Moi ? Jamais de la vie !) les MCUs Renesas ont effectivement une réputation de prix bas (au taf, quand on veut faire du vraiment pas cher on met du RH850) et les codecs AKM n'ont pas de vrais concurrents (Cirrus Logic est hors-de-prix ...).

D'ailleurs, je suis prêt à parier que ce circuit est présent à l'identique dans d'autres effets numériques de la marque, avec juste un autre firmware, une couleur de boîtier et une sérigraphie différente. Ça commence à se répandre dans le milieu des pédales d'effet, TC Electronic étant un exemple flagrant (DSP Analog Devices - luxe - et codec AKM). Ou Zoom, dont il semble que tous les multi-effets partagent les mêmes effets, en tous cas la même base de firmware, vu qu'il est possible d'uploader n'importe quel effet de n'importe quelle pédale dans n'importe quelle autre. Pas officiellement cela va de soi, il faut passer par un logiciel développé par des hackers - avec hoodie noir / masque de Guy Faulkes / accent russe CELA VA DE SOI - comme expliqué dans cette vidéo:

https://www.youtube.com/watch?v=Ul-BYkV3PSk

Alors bon, on peut se scandaliser de cette tendance au tout-numérique, perso je trouve que ça a du sens tant qu'il n'y a pas d'arnaque, genre des pédales avec un prix différent à iso-hardware. Je suis un grand fan des pédales TC Electronic, dont le système toneprint permet de reconfigurer les effets via un logiciel sur PC, et permet même de réassigner les potars, jusqu'à 3 paramètres par potar avec des courbes de réponses séparées éditables pour chaque :coeur: Je trouve ça ultra-efficace et ultra-pratique ! Ce qui fait que je me tâte à craquer pour le plethora X5, qui est tout simplement une version multi-effet de ça. Mais bon, 1) je n'ai plus de groupe en activité pour m'en servir et 2) les premiers retours pointent une fiabilité catastrophique, ce qui m'incite à ne pas me précipiter. Au passage, sur les pédales toneprint que j'ai et que j'ai ouvert il y a aussi des codecs AK4552 ou AK4556, ces composants sont vraiment très répandus.

BREF, revenons à nos moutons. N'ayant pas de piste évidente, je commence par passer tous les tests de diagnostic, en regardant à l'oscillo ce qu'il sort. Rien à signaler, tous les tests passent sans problème. Puis je mesure les alimentations, et là je vois un truc bizarre : le rail 3.3V de l'ASIC est à ~7V. D'ailleurs, je remarque que l'ASIC chauffe beaucoup. Genre VRAIMENT beaucoup. Ceci explique cela. Il est donc probable qu'il ne fonctionne pas très bien, ce qui expliquerait les comportements eratiques. Après, au pire cas il est peut-être carrément endommagé, et là je ne pourrai pas faire grand-chose.

Regardons côté alimentation : le 3.3V est généré à partir de l'alimentation 9V via un buck:

sch-DCDC.PNG
sch-DCDC.PNG (29.08 Kio) Vu 363 fois


Rien de spécial à signaler, c'est un buck tout ce qu'il y a de plus classique, avec un contrôleur intégré et un MOS externe. A l'oscillo je constate qu'il y a à peut près la même tension en entrée et en sortie du circuit, ce qui peut signifier soit que le contrôleur est mort et ne découpe plus, soit que le MOS est mort et bloqué fermé. Je met un coup d'oscillo sur la gate du MOS (pin 1 du MOS, pin 4 de IC6) : ~0V, donc le MOS est maintenu fermé. Normalement on doit voir un signal de découpage à haute fréquence. Si on regarde la doc du contrôleur S-8520E33MC on constate que le modèle "E" découpe à 300kHz. Or là le signal est bloqué à 0. On a bien 9V sur la pin 1 (ON/OFF) donc tout semble accuser le contrôleur qui doit être mort. J'en ai commandé un sur Mouser, et aussi un MOSFET de remplacement.

Heureusement le contrôleur est encore vendu, mais bien entendu, le MOSFET, lui, est obsolète et plus distribué (2SJ190 NEC / Sanyo, encore du japonais, décidément ...). Donc j'ai tâché de trouver un équivalent. Dans ce genre de cas, il faut prendre exactement le même boîtier, et tâcher de s'approcher au niveau des caractéristiques critiques : Rds-on (prendre idéalement égal ou inférieur), capa de grille (égal ou inférieur), tension D-S max (égal ou supérieur), tension G-S max (égal ou supérieur), tension de seuil Vgs-th (égal ou inférieur). Si on arrive pas à trouver une réréence qui satisfait toutes ses conditions, il faut regarder le contexte du circuit.

Par exemple, la tension Vgs-th est très proche de zéro sur ce MOS, -1V à -2V, donc difficile de trouver un MOS avec une tension de seuil aussi faible. Mais si on regarde la doc du contrôleur, il est indiqué dans la section sur le choix du switch externe (p19 section 5.1) "The EXT pin swings from voltages between VIN to VSS", ce qui signifie que la pin de commande de grille va découper en 0-9V, donc un PMOS avec un seuil à 3V voir 5V va parfaiement fonctionner. D'une façon générale, on peut se fier entièrement à cette section de la doc pour choisir un PMOS de remplacement. Moi j'ai pris un PCP1302-TD-H qui correspond, est pas cher et avec un bon stock chez Mouser.

Bon, maintenant il faut les changer.

IMG_20200918_173414.jpg
IMG_20200918_173414.jpg (556.61 Kio) Vu 363 fois


Le dé-soudage se passe bien au fer à souder, les boîtier ont peu de pattes donc on peut les lever petit-à-petit sans difficulté. En plus la semelle du MOS ne se prolonge pas tout le long du boîtier, donc pas besoin de trop insister pour le lever.

IMG_20200918_175047.jpg
IMG_20200918_175047.jpg (483.13 Kio) Vu 363 fois


Une fois re-soudé:

IMG_20200918_180329.jpg
IMG_20200918_180329.jpg (576.1 Kio) Vu 363 fois


Je me suis rendu compte après avoir fait le changement qu'il y avait la caméra macro que Zenos a ramené récemment pour faire de la vidéo de manips sur la table à côté ... C'est con, j'aurais dû filmer. Bon, tant pis, une autre fois.

A noter : les connections aux jacks sont très fragiles, les fils ne sont pas étamés et ils cassent facilement. A ma première re-fermeture de la boîboîte, il y en avait deux qui avaient lâché ... Je n'arrête pas de le dire et le répéter : il faut ETAMER les fils avant de les souder, sinon c'est trop fragile.

IMG_20200918_173146.jpg
IMG_20200918_173146.jpg (420.08 Kio) Vu 363 fois


Ça a l'air de marcher, tous les effets réagissent maintenant, ça sature pas mal par contre, et le potar de volume déconne pas mal, mais c'est ptet parce qu'il est encrassé ...
Avatar de l’utilisateur
NicoM
Electrolab::Membre
Messages : 138
Enregistré le : 01 mars 2017, 16:05
Localisation : Chez oim
Contact :

Re: Réparation BOSS SYB-5 Bass Synthesizer

Messagepar NicoM » 13 nov. 2020, 17:26

A propos des codec AKM, voilà qui va faire les affaires de Cirrus
http://www.semimedia.cc/?p=8523
Avatar de l’utilisateur
Eric
Electrolab::Référent
Messages : 351
Enregistré le : 09 mars 2017, 10:09
Localisation : Electrolab
Référent : Zone Élec

Re: Réparation BOSS SYB-5 Bass Synthesizer

Messagepar Eric » 13 nov. 2020, 18:13

Sympa la réparation. Une chance que les CI aient survécu au 9V (que l'un d'entre eux limitait à 7V).
Je suppose que ce genre de pédale d'effet est alimentée par une pile de 9V qui a une résistance interne relativement élevée et ne peut fournir plus de 50-100 mA Mais bon, pour des circuits très sensibles, 100mA c'est déjà trop si on les survolte.

Eric
...fait de l'effet

@NicoM: Intéressant l'article : ils ont mis 3 jours pour éteindre l'incendie dans l'usine AKM ! Même dans le tunnel du Mont Blanc on a réussi à éteindre plus vite.
Les japonais ont pas voulu utiliser d'eau pour limiter les dégâts ? Ou les pompiers ont carrément fait demi-tour quand on leur a expliqué que pour fabriquer des semiconducteurs on n'utilisait QUE des produits dangereux et toxiques?
Avatar de l’utilisateur
Flax
Electrolab::CA
Messages : 1011
Enregistré le : 01 mars 2017, 20:46
Contact :

Re: Réparation BOSS SYB-5 Bass Synthesizer

Messagepar Flax » 17 nov. 2020, 11:30

Petit update quand-même tant que j'y pense : après des tests plus intensifs, la pédale se met en rade au bout de quelques minutes, et ça sature toujours beaucoup, donc je pense que certains composants ont dû prendre trop cher. Le DSP a l'air de fonctionner correctement, on entend les effets et les boutons ont une action cohérente sur le son, je suspecte donc le codec, sûrement son front-end / back-end analogique a dû manger, ce qui expliquerait les saturations. Et ptet le DSP a quand-même pris un coup s'il se met en rade, mais ça peut aussi être le codec qui n'arrive plus à convertir les signaux.

Bon, je ne vais pas passer plus de temps sur cet effet, pas envie et là ça devient trop de boulot, et trop boîte noire.
Avatar de l’utilisateur
Eric
Electrolab::Référent
Messages : 351
Enregistré le : 09 mars 2017, 10:09
Localisation : Electrolab
Référent : Zone Élec

Re: Réparation BOSS SYB-5 Bass Synthesizer

Messagepar Eric » 17 nov. 2020, 16:49

Hello,

Oui bien sur, pour un équipement somme toute assez classique (et sans valeur historique/sentimentale particulière), le temps de réparation doit rester raisonnable.
Changer le codec serait certes encore possible si on trouve le composant, pour le DSP surtout s'il est préprogrammé, c'est clairement overkill.

Il y a quelques temps, j'ai réparé un oscilloscope qui a fait de la fumée : le filtre secteur a cramé, avec en prime cette odeur infâme qui colle à tout. C'est une panne très bête mais hélas assez classique. Et tant que la pièce n'est pas remplacée, on ne peut plus se servir de l'appareil - bien qu'il fonctionne quand même - car il risque de faire sauter le disjoncteur. Et évidemment, pour avoir accès à l'embase secteur-filtre, il faut préalablement démonter pleins de sous-ensembles :(
J'avais préparé du texte et des photos concernant la réparation (ou plus exactement concernant un ajout fait en même temps que le changement du filtre) : voilà que c'est enfin publié.

Eric
...sent le roussi

Retourner vers « BlaBla... »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité